Jump to content


Member Since 25 Aug 2006
Offline Last Active Today, 01:07 PM

Topics I've Started

Trying to run GPL @ 4k resolution, not working

20 June 2019 - 05:41 AM

Hi guys,

I think I may need some help here. I've gotten myself a new 31.5" screen that is running 3840x2160 native. Once you get
used to the sheer size, which really doesn't take that long, you start playing around with it. Since getting it yesterday, I've
tried a couple of current games and wanted to have a go at GPL now. Sad thing is - I can't make it cooperate. Now, what
do I mean by that?
Well basically I can start GEM or even GPL direct from the file explorer and get into the actual game. However, in there I
only get about the top left quarter stretched to the limits of my screen. So essentially I see a 320x240 slice of the GPL
menu stretched to 3840x2160. Needless to say trying to navigate that is not working as you're missing 3/4 of the menu,
in particular the once with the actual green button on it.
I tried fiddling with the settings in core.ini for the V2 rasterizers, changed those from 0 / 0 to 3840 / 2160 respectively,
no sale. Tried setting the UHD resolution via GEM's rasterizer "menu" - also no sale. Tried changing that whole lot to the
FHD rsolution (1920 / 1080), again no can do, sir.

For what it's worth, I'm trying to run the OGL v2 rasterizer as the Direct-X one used to not like NVidia cards that much
recently. Also I was under the impression, that D3D v7 is somewhat limited in max resolution. I think it is capable of just
over FHD, but not 4k resolution. <sigh>

What am I missing?

just tried again with D3D v2, resolution per GEM: 1920x1080. Same result. And what's most annoying about all that,
when I try to Alt+Tab out of the game, the resolution stays at what I assume is 640x480 with GPL showing full screen.
Also invoking the taskmanager via Shift+ESC or trying to quit GPL via Alt+F4 do not work, so I basically have to sign
out and log back in with everything else gone in the mean time. That honestly sucks badly.